
As you use them repeatedly, you'll develop a sense for what's good code and what's bad code.
I'll also sprinkle some general Laravel code advice in between these tactics.
THREAD

Using some "macro" philosophy for structuring your code, like hexagonal architecture or DDD won't save you.
A clean codebase is the result of constant good decisions at the micro level.

The code will be cleaner & more readable and you will see understandable exceptions if something goes wrong. No half-passing edge cases.

Too much nesting & else statements tend to make code harder to read.

Opening an array with [ and indenting the values tends to work well. Same with long function parameter values.
Other good places to split lines are chained calls and closures.

The opposite of the previous tip. Sometimes the value comes from a complex call and as such, creating a variable improves readability & removes the need for a comment.
Remember that context matters & your end goal is readability

Your controllers should be simple. They should say things like "create invoice for order". They shouldn't be concerned with the details of how your database is structured.
Leave that to the model.

Let's expand on the previous example. Sometimes, creating a class for a single action can clean things up.
Models should encapsulate the business logic related to them, but they shouldn't be too big.

They're a great place to hide complex validation logic.
But beware of exactly that — hiding things. When your validation logic is simple, there's nothing wrong with doing it in the controller. Moving it to a form request makes it less explicit

Consider offloading some logic from controllers to events. For example, when creating models.
The benefit is that creating these models will work the same everywhere (controllers, jobs, ...) and the controller has one less worry about the details of the DB schema

If some method is too long or complex, and it's hard to understand what exactly is happening, split the logic into multiple methods.

If you repeat some code a lot, consider if extracting it to a helper function would make the code cleaner.

Sometimes people put helpers into a class.
Beware, it can get messy. This is a class with only static methods used as helper functions. It's usually better to put these methods into classes with related logic or just keep them as global functions.

Know the difference between static/instance methods & variables and private/protected/public visibility. Also learn how Laravel uses magic methods.
You don't need this as a beginner, but as your code grows, it's crucial.

This ties the previous tweet with the other tips here. OOP exists to make your code more readable, use it. Don't just write 400 line long procedural code in controller actions.
Here's code from my first Laravel project


Avoid having classes that deal with many unrelated things
But, for the love of god, don't create a class for every single thing. You're trying to write clean code. You're not trying to please the separation gods

1. The function has too many responsibilities. Separate.
2. The responsibilities are fine, but you should refactor the long signature.
Below are two tactics for the fixing second case.

Rather than passing a huge amount of arguments in a specific order, consider creating an object with properties to store this data.
Bonus points if you can find that some behavior can be moved into to this object.

You can also create objects with fluent APIs. Gradually add data by with separate calls, and only require the absolute minimum in the constructor.
Each method will return $this, so you can stop at any call.

Creating custom collections can be a great way to achieve more expressive syntax. Consider this example with order totals.

Don't think that long variable/method names are wrong. They're not. They're expressive.
Better to call a longer method than a short one and check the docblock to understand what it does
Same with variables. Don't use nonsense 3-letters abbreviations

If you can, only use the 7 CRUD actions in your controllers. Often even fewer.
Don't create controllers with 20 methods.
More shorter controllers is better.

Rather than thinking "what can this object do", think about "what can be done with this object". Exceptions apply, such as with action classes, but this is a good rule of thumb.

Adding methods to classes where they belong is cleaner than creating action classes for everything, but it can make the classes grow big
Consider using traits. They're meant *primarily* for code reuse, but there's nothing wrong with single-use traits

Similar to single-use traits.
This tactic is great when you have a very long template and you want to make it more manageable.
There's nothing wrong with @including headers and footers in layouts, or things like complex forms in page views.

Sometimes you may have multiple classes with the same name. Rather than importing them with an alias, import the namespaces.

Rather than writing complex where() clauses, create query scopes with expressive names.
This will make your e.g. controllers have to know less about the database structure and your code will be cleaner.

If you want to retrieve some data from a model, create an accessor.
Keep methods for things that *change* the model in some way.

You can store things like "results per page" in config files. Don't add them to the app config file though. Create your own. In my e-commerce project, I use config/shop.php.

Instead of writing controller actions like PostController@index, use the callable array syntax [PostController::class, 'index'].
You will be able to navigate to the class by clicking PostController.

If you have a complex route action, consider moving it to a separate controller.
For OrderController::create, you'd create CreateOrderController.
Another solution is to move that logic to an action class — do what works best in your case.

Install extensions, write annotations, use typehints. Your IDE will help you with getting your code working correctly, which lets you spend more energy on writing code that's also readable.

Above you can see that I use space between ! and the value I'm negating. I like this, because it makes it clear that the value is being negated. I do the same around dots.
Decide if you like it. It can (imo) clean up your code.

This is largely a matter of personal preference, but calling a global function instead of having to import a class and statically call a method feels nicer to me.
Bonus points for session('key') syntax.

You can make your Blade templates more expressive by creating custom directives. For example, rather than checking if the user has the admin role, you could use @admin.

Sometimes you may want to execute DB queries in blade. There are some ok use cases for this, such as in layout files.
But if it's a view returned by a controller, pass the data in the view data instead.

ALWAYS use strict comparison (=== and !==). If needed, cast things go the correct type before comparing. Better than weird == results
Also consider enabling strict types in your code. This will prevent passing variables of wrong data types to functions

Many people will disagree with this, because they do it. But it makes no sense.
There's no point in using docblocks when they don't give any extra information. If the typehint is enough, don't add a docblock.
That's just noise.

If you validate some resource's attributes on multiple places, you definitely want to centralize these validation rules, so that you don't change them in one place but forget about the other places. https://twitter.com/LiamHammett/status/1260252814158282752

Don't turn all arrays into collections just because Laravel offers them, but DO turn arrays into collections when you can make use of collection syntax to clean up your code.

Functional code can both clean things up and make them impossible to understand. Refactor common loops into functional calls, but don't write stupidly complex reduce()s just to avoid writing a loop. There's a use case for both.

Before writing a comment, ask yourself if you could rename some things or create variables to improve readability. If that's not possible, write the comment in a way that both your colleagues and you will understand in 6 months.

Above I said that moving business logic to action/service classes is good. But context matters
Here's code design advice from a popular "Laravel best practices" repo. There's absolutely no reason to put a 3-line check into a class. That's just overengineered

*Your goal to write more readable code.*
Your goal is NOT to do what someone said on the internet
These tips are just tactics that tend to help with clean code. Keep your end goal in mind and ask yourself "is this better?"